En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 
 
 
 
 
Vous êtes ici :   Accueil » Administrer Guppy en local

Webmaster - Infos

Préférences


Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe


  2077333 visiteurs
  4 visiteurs en ligne

  34 membres
Connectés :
( personne )
Snif !!!
    Imprimer la page...
    Imprimer la section...

Administrer Guppy en local

Administrer Guppy en local

Pour administrer Guppy en local et le faire fonctionner, il vous faut un serveur qui gère le langage PHP.

EasyGuppy, faisait ça très bien, mais il semble qu'aujourd'hui, son créateur ne le met plus à jour, ce qui pose quelques problèmes de fonctionnement avec la nouvelle version de Guppy, la V4.6.

D'autres serveurs fonctionnent très bien, comme "Xampp", "EasyPhp1_8", ou ZazouMiniWebServer, il suffit d'en choisir un, de le télécharger et de l'installer.

Personnellement, j'ai choisi EasyPhp avec lequel je travaille depuis plusieurs années, mais vous êtes libre de choisir celui qui vous plaît le mieux, c'est à dire, celui qui vous facilite la vie.

Comme son nom l'indique, EasyPHP permet de simplifier le travail sur les fichiers au format PHP.
En effet, ce format nécessite d'être interprété, ce qu'un simple navigateur Web ne peut pas faire.
EasyPHP vous offre donc la possibilité de travailler dans un environnement serveur complet.
L'application comprend un serveur Apache, une base de données MySQL, la dernière version de PHP, et tous les outils nécessaires pour travailler sur le code PHP et créer votre site

J'ai choisi EasyPhp1_8 et afin vous faciliter la vie pour le télécharger, cliquer :

Nota : Il gère le PHP4, très utile pour les sites Guppy V4.5 et V4.6 qui ont des plugins non compatibles V4.6.
Quand le PHP5 sera généralisé, ce qui ne saurait tarder, il faudra passer aux versions supérieures de EasyPhp ou de
WampServer.

Nous sommes maintenant en Novembre 2010, il est temps de passer à la Version PHP 5.3.3, car si vous voulez vous assurer que votre site est compatible avec le PHP 5, il ne faut plus travailler avec des versions réservées au PHP4, de nombreuses fonctions ont changées et si vous mettez en ligne votre site chez un hébergeur en PHP 5, vous risquez d'avoir des surprises désagréables. mad
Pour les débutants, je me suis rendu compte que "WampServer" était plus facile à maîtriser, c'est toujours bon à savoir. cool


Aujourd'hui, en Novembre 2016, la version de Guppy fonctionne avec minimum, PHP 5.4.

J'ai téléchargé "EasyPHP - Devserver-16.1 qui permet d'être en PHP 5.6 minimum pour pouvoir administrer mon site en local. (Sur mon Ordinateur, sans passer par Internet).

Petit inconvénient, il est en anglais.

Voici le lien de téléchargement :

Si vous rencontrez des difficultés pour l'utiliser, allez faire un tour sur mon "Forum" dans ce "fil" ,tout est expliqué.


Juillet 2017

Voici un excellent tuto trouvé sur Internet :

Pour ceux qui comme moi, utilisent une base de données "MySql", (Mon Forum, mon Blog, mon Album Photos, mon livre d'or), et qui rencontrent certaines difficultés pour "exporter" leur base de données trop volumineuse, afin de l'utiliser en local avec "PhpMyAdmin", ce qui m'est arrivé avec la base "MyQql" de mon Forum, voici également un lien pour vous aider.


Date de création : 11/10/2007 - 11:09
Dernière modification : 08/03/2019 - 16:49
Catégorie : Création de Sites - Bon à savoir
Page lue 11460 fois


Réactions à cet article


Réaction n°1 

par AUBERT_HENRI le 14/12/2015 - 11:20
C'est un véritable trésor que le site d'Henri, on y trouve plein de choses utiles.

Derniers Messages de mon Forum PhpBB3

forum.gif

Lire la suite

Derniers Messages de mon Livre d'or Alex_GuestBook

livredor.gif

Utilisateur de Guppy, je suis membre de l'association "FreeGuppy", et vous ???



ban_asso_rv.gif

Lire la suite

livredor.gif

Utilisateur de Guppy, je suis membre de l'association "FreeGuppy", et vous ???



ban_asso_rv.gif

Fermer

Le Vide-grenier de Henri Chéli

houa.gif

Devant l'abondance de matériel informatique récupéré çà et là, et remis en état,

j'ai décidé d'ouvrir un Vide Grenier.

C'est aussi une façon pour moi de faire l'inventaire de mes trésors. smile

N'hésitez pas à vous renseigner.

Mise à jour du Plugin "QuickCart V5" en V6.7 par "Linuxmr" le 19/03/2018

Ce Plugin "Boutique", remis à jour par LINUXMR est à nouveau disponible en V6.01 depuis le 14 Janvier 2019

vide-grenier.jpg>

Cliquez là ou ci-dessous, ou dans le Menu  nouveau4.gif

Lire la suite

houa.gif

Devant l'abondance de matériel informatique récupéré çà et là, et remis en état,

j'ai décidé d'ouvrir un Vide Grenier.

C'est aussi une façon pour moi de faire l'inventaire de mes trésors. smile

N'hésitez pas à vous renseigner.

Mise à jour du Plugin "QuickCart V5" en V6.7 par "Linuxmr" le 19/03/2018

Ce Plugin "Boutique", remis à jour par LINUXMR est à nouveau disponible en V6.01 depuis le 14 Janvier 2019

vide-grenier.jpg>

Cliquez là ou ci-dessous, ou dans le Menu  nouveau4.gif

Fermer

Guppy 5.02.02 et Nouveautés magiques

Guppy 5.02.02

guppy.gif

Et voici Guppy 5.0.0.2, la 100ème version de Guppy. Dans quelques jours, Guppy aura 15 ans. La première version de miniPortail est sortie le 30 décembre 2002. Pour cette 100ème version, deux nouveautés importantes font leur apparition.

- l'intégration du plugin jQuery Unite-Gallery, y compris la partie administration.

- l'intégration du plugin jQuery Liquid Slider, y compris la partie administration.

Un grand "Bravo" à "Saxbar", à Papinou et à la "GuppyTeam" pour toutes ces nouveautés.

Unite-Gallery

photo.gif

Unite Gallery est un plugin jQuery responsive, pour des galeries de photos et de vidéos. Cette galerie puissante et rapide, a toutes les fonctionnalités nécessaires, responsive, réactive au toucher et même un effet zom.
Responsive - s'adapte à chaque écran avec préservation automatique du ratio et peut répondre à un changement de taille d'écran.
Toucher - Toutes les parties de la galerie peuvent être contrôlées par des dispositifs tactiles.
Skinnable - Possibilité de changer de skins avec facilité dans différents fichiers css sans toucher la galerie principale css.
Thèmes - plusieurs thèmes, chaque thème a ses propres options et fonctionnalités, mais il utilise les objets de base de la galerie.
Effet Zoom - un effet zoom unique qui peut-être appliqué à l'intérieur des boutons, de la molette de la souris ou d'un geste de pincement au toucher.
Thème Vidéo - à partir de : Youtube, Vimeo, HTML5, Wistia.

Liquid Skidery

ordinateur.pngsmartphone.pngtablettes.png

Liquid Slider est un Slider jQuery Responsive, ce qui sous-entend créer dans le but de s'adapter à tous les terminaux et par conséquent aux différentes tailles d'écran.

Il présente des transitions CSS3, utilise "animate.css", la navigation dynamique par glisser-déplacer, et plus encore.

Puissant, facile à utiliser et rapide.

Il est entièrement réactif et totalement adaptable aux changements de largeur et d'orientation, utilisant des animations CSS3 modernes pour forcer l'acquisition matérielle sur les périphériques mobiles, vous n'aurez jamais à vous soucier des transitions lentes ou rapides.